Increased failures in patient search module (Epic/Cerner Integration)

Incident Report for Green Security System Status

Resolved

We have restored the previous keys yesterday and via monitoring have found that all patient search functionality is working as it has previously. We encourage all customers to reach out to their CSM to plan for a migration to a tenant specific JWK Set URL.
Posted Sep 15, 2026 - 17:03 UTC

Monitoring

We have identified the issue as a rotated JWK Set key that was not picked up by Epic. Your CSM will reach out with a new per-tenant JWK Set URL (newly required best practice from Epic) to re-fetch the newest keys for your instance. These URLs properly handle key rotations.
Posted Sep 14, 2026 - 16:53 UTC

Identified

We have identified the issue and are working through a fix.
Posted Sep 14, 2026 - 14:59 UTC

Investigating

We are currently investigating an issue where the patient search integration with Epic/Cerner through the FHIR interface is experiencing an increase in `invalid_client` errors.
Posted Sep 14, 2026 - 13:56 UTC
This incident affected: Visitor Management (Visitor Management Portal).