Elevated System Errors

Incident Report for Green Security System Status

Resolved

This incident has been resolved
Posted Dec 06, 2025 - 14:43 UTC

Monitoring

We have resolved login/SSO issues as well as the duplicate emails being sent out to vendors.

We are working with our email provider to fix email delivery issues.
Posted Dec 05, 2025 - 18:20 UTC

Investigating

We're experiencing an elevated level of system errors and are currently looking into the issue.

We are investigating an issue with duplicated emails sent to vendors.
We are investigating login/SSO issues for hospital employees.
Posted Dec 05, 2025 - 14:35 UTC
This incident affected: Platform and Green Security App.